0 suara
615 tampilan

Because of needing to convert our project in order to normalize the Unicode data, we’re working with project that is at “Stage 2 of 3” in the registration status. As a result, the project is not on the Send/Receive server and this during a consultant check. :face_with_raised_eyebrow: Is there something that I/we need to do to move this ahead? It has been in stage 2 for four days now. The project GUID is: d826c0a1849189e92e4f373723166e173b8142b4 if that helps any tech to figure out what’s going on.

TIA!
anon619977

Postingan lama - ditampilkan dalam bahasa aslinya
Paratext oleh (120 poin)
ditampilkan kembali | 615 tampilan

6 Jawaban

0 suara
Jawaban terbaik

That project is already fully registered. After registration, there is a period of time where other people can dispute it (that’s stage 2), but it does not affect the ability of the project to be S/R.

The fact that the project is not yet on the S/R says to me that it just has not been S/R’d since it was converted. Check Project > Project Properties and Settings and Project > Users, Roles and Permissions. If the project shows as registered in the Project Properties and Settings, then everything is fine with the registration.

FWIW, You can change the normalization of the project without needing to convert it.

Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)

Thanks for the response. I’m not sure why, but doing a S/R hadn’t worked though I’d tried it multiple times. Just now it did work so that great. Now to get the modifications to sync correctly (modifications were made on another computer in an instance that we restored from a backup file).

If that’s the case, then the documentation needs to be changed (see below).

[How do I make my Paratext project data consistent?]

For an existing project:
If your project has data with a mix of composed and decomposed characters (likely due to using different keyboard layouts), do the following to force all the data to be consistent.

  1. Click in the window of the project, to make it the active window.
  2. From the Tools menu, point to Advanced and select Convert Project.
  3. In the “New Project short name” box, enter a unique short name.
  4. Select one of the following in the Normalization drop-down list.
  • Composed (NFC) (for data to be saved as composed characters).
  • Decomposed (NFD) (for data to be saved as decomposed characters).
  1. Click Convert.
    Paratext creates a new project in which all data will be saved in the normalization option you chose.
Postingan lama - ditampilkan dalam bahasa aslinya
0 suara

It was true in PT7 and earlier versions of PT8 that you needed to use Convert Project, but the latest versions of PT8 should be able to do it just by changing the option in Project > Properties and Settings > Advanced tab. Which version of Paratext were you using?

Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)

8.0.100.75

That’s what it seemed like to me, but I didn’t want to mess something up by not following “protocol”. :stuck_out_tongue:

Postingan lama - ditampilkan dalam bahasa aslinya
0 suara

I’ll let the documentation person know that the documentation is out-of-date. Thanks.

Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)

Thanks!
Do you know whether computer B can simply do a S/R now? I did the conversion on computer A, then due to not being able to S/R, I made a backup on A and restored on B. All edits in the past few days have been on B except for adding notes on A.

Postingan lama - ditampilkan dalam bahasa aslinya
0 suara
Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)
0 suara
Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)
0 suara

Computer B should have a copy of the project with a different ID (GUID). They are effectively different projects now because a Restore was used. (As a general rule, do not mix Backup/Restore with S/R. Bad things happen to projects that do this, generally.) If nothing else was changed on another computer, what you can do is the following on computer B:

  • Copy the files of the restored project to a different, temporary directory. You will probably want to not copy the notes files since you made changes to them on another computer.
  • Delete the restored project.
  • Do a S/R of the project.
  • Copy the files you moved to a different directory back over top of the files in the project that was just S/R’d. Do NOT copy over the .hg directory or bad things will happen!!!
    If you know what was changed on the project, it would be best if only those files were copied over.
  • Verify that all the changes you are expecting are there and that everything still “works” and then do a S/R.

EDIT: If there are only edits to the main text on computer B, you can do a safer approach and use Tools > Compare Texts with the two projects (would require renaming the restored project on disk)

Postingan lama - ditampilkan dalam bahasa aslinya
oleh [Expert]
(16,7k poin)

ditampilkan kembali

Pertanyaan terkait

0 suara
2 jawaban 258 tampilan
Currently in a PT8 Migration Workshop. We had a PT7 user with a misconfigured Back Translation in PT7, so it ... Files error when re-migrating the project. Thanks, listentwice
listentwice 1,2k bertanya Nov 6, 2017
0 suara
0 jawaban 153 tampilan
In Paratext 8.0, you must register projects created in earlier versions of Paratext if you want to use all the features of ... /t/how-do-i-register-a-project-in-paratext-8/1186)
[Expert]
anon421222
735
bertanya Feb 23, 2017
0 suara
1 jawaban 337 tampilan
Seorang mantan MTT tertarik untuk mengatur proyek Paratext. Proyek terdaftar yang sedang ia kerjakan telah ... pertanyaan serupa di sini tetapi tidak berhasil melakukannya.
chas 113 bertanya Jun 20, 2023
0 suara
5 jawaban 662 tampilan
Dear All, I have added (registrered) a new user in the registry website. It seems to have worked and I was promised to ... me to do? Thanks for any help you can give. goodgoan .
goodgoan 347 bertanya Jan 7, 2020
0 suara
3 jawaban 718 tampilan
I deleted the user's folder under the PT9 Proj folder, but it still opens as registered to the old user. How do I ... installed. I do not yet have the new user's registration info.
listentwice 1,2k bertanya Nov 27, 2019
Welcome to Support Bible, where you can ask questions and receive answers from other members of the community.
And let us consider how we may spur one another on toward love and good deeds, not giving up meeting together, as some are in the habit of doing, but encouraging one another—and all the more as you see the Day approaching.
Hebrews 10:24-25
3,045 pertanyaan
6,005 jawaban
5,671 komentar
2,026 pengguna