0
624 次瀏覽

Because of needing to convert our project in order to normalize the Unicode data, we’re working with project that is at “Stage 2 of 3” in the registration status. As a result, the project is not on the Send/Receive server and this during a consultant check. :face_with_raised_eyebrow: Is there something that I/we need to do to move this ahead? It has been in stage 2 for four days now. The project GUID is: d826c0a1849189e92e4f373723166e173b8142b4 if that helps any tech to figure out what’s going on.

TIA!
anon619977

舊文章 - 以原文顯示
Paratext (120 點) 提出
已重新顯示 | 624 次瀏覽

6 個回答

0
最佳回答

That project is already fully registered. After registration, there is a period of time where other people can dispute it (that’s stage 2), but it does not affect the ability of the project to be S/R.

The fact that the project is not yet on the S/R says to me that it just has not been S/R’d since it was converted. Check Project > Project Properties and Settings and Project > Users, Roles and Permissions. If the project shows as registered in the Project Properties and Settings, then everything is fine with the registration.

FWIW, You can change the normalization of the project without needing to convert it.

舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出

Thanks for the response. I’m not sure why, but doing a S/R hadn’t worked though I’d tried it multiple times. Just now it did work so that great. Now to get the modifications to sync correctly (modifications were made on another computer in an instance that we restored from a backup file).

If that’s the case, then the documentation needs to be changed (see below).

[How do I make my Paratext project data consistent?]

For an existing project:
If your project has data with a mix of composed and decomposed characters (likely due to using different keyboard layouts), do the following to force all the data to be consistent.

  1. Click in the window of the project, to make it the active window.
  2. From the Tools menu, point to Advanced and select Convert Project.
  3. In the “New Project short name” box, enter a unique short name.
  4. Select one of the following in the Normalization drop-down list.
  • Composed (NFC) (for data to be saved as composed characters).
  • Decomposed (NFD) (for data to be saved as decomposed characters).
  1. Click Convert.
    Paratext creates a new project in which all data will be saved in the normalization option you chose.
舊文章 - 以原文顯示
0

It was true in PT7 and earlier versions of PT8 that you needed to use Convert Project, but the latest versions of PT8 should be able to do it just by changing the option in Project > Properties and Settings > Advanced tab. Which version of Paratext were you using?

舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出

8.0.100.75

That’s what it seemed like to me, but I didn’t want to mess something up by not following “protocol”. :stuck_out_tongue:

舊文章 - 以原文顯示
0

I’ll let the documentation person know that the documentation is out-of-date. Thanks.

舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出

Thanks!
Do you know whether computer B can simply do a S/R now? I did the conversion on computer A, then due to not being able to S/R, I made a backup on A and restored on B. All edits in the past few days have been on B except for adding notes on A.

舊文章 - 以原文顯示
0
舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出
0
舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出
0

Computer B should have a copy of the project with a different ID (GUID). They are effectively different projects now because a Restore was used. (As a general rule, do not mix Backup/Restore with S/R. Bad things happen to projects that do this, generally.) If nothing else was changed on another computer, what you can do is the following on computer B:

  • Copy the files of the restored project to a different, temporary directory. You will probably want to not copy the notes files since you made changes to them on another computer.
  • Delete the restored project.
  • Do a S/R of the project.
  • Copy the files you moved to a different directory back over top of the files in the project that was just S/R’d. Do NOT copy over the .hg directory or bad things will happen!!!
    If you know what was changed on the project, it would be best if only those files were copied over.
  • Verify that all the changes you are expecting are there and that everything still “works” and then do a S/R.

EDIT: If there are only edits to the main text on computer B, you can do a safer approach and use Tools > Compare Texts with the two projects (would require renaming the restored project on disk)

舊文章 - 以原文顯示
[Expert]
(16.7k 點) 提出

已重新顯示

相關問題

0
2 個回答 258 次瀏覽
Currently in a PT8 Migration Workshop. We had a PT7 user with a misconfigured Back Translation in PT7, so it ... Files error when re-migrating the project. Thanks, listentwice
listentwice 1.2k 提出 已提問 11月 6, 2017
0
0 個回答 153 次瀏覽
In Paratext 8.0, you must register projects created in earlier versions of Paratext if you want to use all the features of ... /t/how-do-i-register-a-project-in-paratext-8/1186)
[Expert]
anon421222
735 提出
已提問 2月 23, 2017
0
1 個回答 337 次瀏覽
一位前 MTT 成員有興趣建立一個 Paratext 專案 他之前參與的已註冊專案已暫停一段時間,等待尚未解決的領導層變動 他希望使用 Paratext 進行一些獨立工作(他已經相當熟悉 Paratext) 他能否使用目前版本的 Paratext 為自 ... 專案,但就目前而言,這還是不可能的 感謝您提供任何協助 我試著在這裡尋找類似問題,但未能找到
chas 113 提出 已提問 6月 20, 2023
0
5 個回答 662 次瀏覽
Dear All, I have added (registrered) a new user in the registry website. It seems to have worked and I was promised to ... me to do? Thanks for any help you can give. goodgoan .
goodgoan 347 提出 已提問 1月 7, 2020
0
3 個回答 718 次瀏覽
I deleted the user's folder under the PT9 Proj folder, but it still opens as registered to the old user. How do I ... installed. I do not yet have the new user's registration info.
listentwice 1.2k 提出 已提問 11月 27, 2019
Welcome to Support Bible, where you can ask questions and receive answers from other members of the community.
Live in harmony with one another. Do not be proud, but be willing to associate with people of low position. Do not be conceited.
Romans 12:16
3,045 個問題
6,005 個回答
5,671 則評論
2,026 位使用者