0
618 次浏览

Because of needing to convert our project in order to normalize the Unicode data, we’re working with project that is at “Stage 2 of 3” in the registration status. As a result, the project is not on the Send/Receive server and this during a consultant check. :face_with_raised_eyebrow: Is there something that I/we need to do to move this ahead? It has been in stage 2 for four days now. The project GUID is: d826c0a1849189e92e4f373723166e173b8142b4 if that helps any tech to figure out what’s going on.

TIA!
anon619977

较早的帖子 - 以原始语言显示
Paratext (120 分) 发布
已重新显示 | 618 次浏览

6 个回答

0
最佳答案

That project is already fully registered. After registration, there is a period of time where other people can dispute it (that’s stage 2), but it does not affect the ability of the project to be S/R.

The fact that the project is not yet on the S/R says to me that it just has not been S/R’d since it was converted. Check Project > Project Properties and Settings and Project > Users, Roles and Permissions. If the project shows as registered in the Project Properties and Settings, then everything is fine with the registration.

FWIW, You can change the normalization of the project without needing to convert it.

较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布

Thanks for the response. I’m not sure why, but doing a S/R hadn’t worked though I’d tried it multiple times. Just now it did work so that great. Now to get the modifications to sync correctly (modifications were made on another computer in an instance that we restored from a backup file).

If that’s the case, then the documentation needs to be changed (see below).

[How do I make my Paratext project data consistent?]

For an existing project:
If your project has data with a mix of composed and decomposed characters (likely due to using different keyboard layouts), do the following to force all the data to be consistent.

  1. Click in the window of the project, to make it the active window.
  2. From the Tools menu, point to Advanced and select Convert Project.
  3. In the “New Project short name” box, enter a unique short name.
  4. Select one of the following in the Normalization drop-down list.
  • Composed (NFC) (for data to be saved as composed characters).
  • Decomposed (NFD) (for data to be saved as decomposed characters).
  1. Click Convert.
    Paratext creates a new project in which all data will be saved in the normalization option you chose.
较早的帖子 - 以原始语言显示
0

It was true in PT7 and earlier versions of PT8 that you needed to use Convert Project, but the latest versions of PT8 should be able to do it just by changing the option in Project > Properties and Settings > Advanced tab. Which version of Paratext were you using?

较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布

8.0.100.75

That’s what it seemed like to me, but I didn’t want to mess something up by not following “protocol”. :stuck_out_tongue:

较早的帖子 - 以原始语言显示
0

I’ll let the documentation person know that the documentation is out-of-date. Thanks.

较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布

Thanks!
Do you know whether computer B can simply do a S/R now? I did the conversion on computer A, then due to not being able to S/R, I made a backup on A and restored on B. All edits in the past few days have been on B except for adding notes on A.

较早的帖子 - 以原始语言显示
0
较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布
0
较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布
0

Computer B should have a copy of the project with a different ID (GUID). They are effectively different projects now because a Restore was used. (As a general rule, do not mix Backup/Restore with S/R. Bad things happen to projects that do this, generally.) If nothing else was changed on another computer, what you can do is the following on computer B:

  • Copy the files of the restored project to a different, temporary directory. You will probably want to not copy the notes files since you made changes to them on another computer.
  • Delete the restored project.
  • Do a S/R of the project.
  • Copy the files you moved to a different directory back over top of the files in the project that was just S/R’d. Do NOT copy over the .hg directory or bad things will happen!!!
    If you know what was changed on the project, it would be best if only those files were copied over.
  • Verify that all the changes you are expecting are there and that everything still “works” and then do a S/R.

EDIT: If there are only edits to the main text on computer B, you can do a safer approach and use Tools > Compare Texts with the two projects (would require renaming the restored project on disk)

较早的帖子 - 以原始语言显示
[Expert]
(16.7k 分) 发布

已重新显示

相关问题

0
2 个回答 258 次浏览
Currently in a PT8 Migration Workshop. We had a PT7 user with a misconfigured Back Translation in PT7, so it ... Files error when re-migrating the project. Thanks, listentwice
listentwice 1.2k 发布 提问于 十一月 6, 2017
0
0 个回答 153 次浏览
In Paratext 8.0, you must register projects created in earlier versions of Paratext if you want to use all the features of ... /t/how-do-i-register-a-project-in-paratext-8/1186)
[Expert]
anon421222
735 发布
提问于 二月 23, 2017
0
1 个回答 337 次浏览
一位前 MTT(圣经翻译培训)学员希望建立一个 Paratext 项目 他之前参与的那个已注册项目因领导层变动尚未解决,已暂停了一段时间 他希望能使用 Paratext 进行一些独立工作(他目前已经相当熟练地使用 Paratext) 他能否使用当前 ... 一个 官方 翻译项目,但目前这还不可能 感谢提供任何帮助 我尝试在这里寻找类似的问题,但没有找到
chas 113 发布 提问于 六月 20, 2023
0
5 个回答 662 次浏览
Dear All, I have added (registrered) a new user in the registry website. It seems to have worked and I was promised to ... me to do? Thanks for any help you can give. goodgoan .
goodgoan 347 发布 提问于 一月 7, 2020
0
3 个回答 718 次浏览
I deleted the user's folder under the PT9 Proj folder, but it still opens as registered to the old user. How do I ... installed. I do not yet have the new user's registration info.
listentwice 1.2k 发布 提问于 十一月 27, 2019
Welcome to Support Bible, where you can ask questions and receive answers from other members of the community.
Don’t you know that you yourselves are God’s temple and that God’s Spirit dwells in your midst?
1 Corinthians 3:16
3,045 个问题
6,005 个回答
5,671 条评论
2,026 位用户